Ouessant : PowerAI, anciennes versions par défaut

La précédente version 3.4 est aussi disponible : l’extensibilité des calculs est limitée aux 4 GPUs d'un seul nœud. Pour mémoire, les frameworks disponibles sont :

Pour utiliser cette version à la place de la version courante, il faut lancer en interactif la commande

module load powerai/3.4

au lieu de

module load powerai

avant de soumettre votre job avec LoadLeveler.

Voici le canevas de job à customiser en fonction du framework que vous souhaitez utiliser :

job
# PowerAI
#BSUB -app docker
# Nom du job
#BSUB -J monJob
# Ficher output et error, ici le meme fichier
#BSUB -e %J.sortie
#BSUB -o %J.sortie
# Réservation exclusive d'un noeud 
#BSUB -x
# Nombre de taches MPI 
#BSUB -n 4
# Binding
#BSUB -a p8aff(1,1,1,balance)
# Nombre de gpu
#BSUB -gpu "num=4:mode=exclusive_process:mps=no:j_exclusive=yes"
# Nombre de tache MPI par noeud
#BSUB -R "span[ptile=4]
# Durée maximum du travail (1 minute)
#BSUB -W 01:00
 
set -x
source /opt/DL/<framework>/bin/<framework>-activate

Plus de détails sur les scripts de soumission, la sélection des GPUs p.ex. sont disponibles sur cette page ; les commandes de contrôle des travaux sont décrites ici.