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New Features: Versions 8.0 to 8.9.1

This document contains information about changes made to TotalView for 
versions 8.0.0 through 8.9.1. While this information lets you know what 
changes have occurred, it doesn’t completely describe these changes. 
More detailed descriptions can be found within the TotalView Users Guide and 
the TotalView Reference Guide.

New Platforms and Compilers for 
Version 8.9.1

New platforms supported are Red Hat Enterprise Linux 6, Red Hat Fedora 
14, and IBM AIX 6.1.5.

New compilers supported are GCC/GFortran 4.5.2, Intel Composer XE 2011 
for Linux and Mac, and PGI 11.2. New MPI environments are Intel MPI 4.0.1 
and POE 5.2. See the TotalView, MemoryScape, and ReplayEngine Platforms and 
System Requirements guide for details.

TotalView 8.9.1 Changes

Enhanced CUDA 
Support

Support for CUDA 3.2 on Linux x86 and Linux x86-64 has been added. The 
following features are included

Support for apps built with the CUDA 3.0, 3.1, or 3.2 SDK
Compatibility with CUDA 3.0, 3.1 or 3.2 drivers
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Support for CUDA function calls on the stack (in addition to the inlined func-
tion support in previous versions)

Handles exceptions in CUDA code
Display of variables in GPU hardware registers
Support for host pinned memory regions
Support for CUDA contexts
New CLI commands for CUDA functionality

Array 
Statistics CLI 

Commands

You can now use a dprint -stats to programmatically gather the array statistics that 
were previously only available in the GUI. These can be directly printed to the TCL 
prompt or placed in a TCL associative array with the -data option.

Array Type 
Inheritance

In the multi-dimensional array display, changes to types made in the variable win-
dow are picked up prior to launching the array display, resulting in the most up-to-
date information.

Enhanced 
Parallel 

Backtrace

We've improved the way we store stack trace data to improve the representation of 
recursive function calls in the parallel backtrace view. In addition, parallel backtrace 
data is now available through the CLI with the dcalltree command.

Platform Changes in Previous Version 8 
Releases

8.9 Changes TotalView supports Red Hat Enterprise Linux 5 Update 4 and 4 Update 8, Fedora 
13, and Ubuntu 9.10. New compilers supported are GCC 4.5.0, GFortran 4.5.0, PGI 
10.6, Intel 11.1, IBM C/C++ 11.1, and IBM Fortran 13.1. New parallel runtimes 
(MPIs) supported are MPICH 1.2.1p1, OpenMPI 1.4.1, Intel MPI 4.0, MVAPICH 1.2, 
MVAPICH2 1.4.1, SGI MPT 1.27, and IBM POE 5.1.

8.8 Changes TotalView supports the Fedora 12 and Ubuntu 9.10 platforms and compiler PGI 
10.1.

8.7 Changes TotalView supports the Fedora 9 and 10 platforms; compilers XLF 12.1, XLC 10.1, 
Intel 11.1, GCC 4.4, gfortran 4.4, and Berkeley UPC 2.8; and parallel environments 
MPICH 2.1 and OpenMP 1.3.

8.6 Changes TotalView supports C/C++ compilers for the IBM Cell Broadband Engine, GNU For-
tran from Red Hat, and the Sony BCU-100 Zego.

8.5 Changes TotalView supports the IBM Cell Broadband Engine.

8.4.1 Changes This release has updated the compilers TotalView supports. Consult the TotalView 
Platforms and System Requirements Guide. for more information.

8.4 Changes TotalView supports Apple Mac OS X 10.5 (Leopard).

8.3 Changes New operating system versions include:

Apple OS X 10.4.5, 10.4.8, and 10.4.9
Fedora Core 7
Ubuntu 6.06

http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
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As always, we have added support for new versions of existing compilers and paral-
lel runtime environments. Consult the TotalView Platforms and System Requirements 
Guide. for more information.

8.2 Changes TotalView 8.2 has added support for the following systems and compilers:

SiCortex supercomputer
Cray XT4 support and APLs integration
Fedora Core 6 
Expanded Mac support

Preliminary Mac OS X Leopard, 64-bit Mac-Intel, and Mac Universal Binaries
Ubuntu 

Ubuntu is a community-developed Linux-based operating system for the desk-
top, laptop, thin client and server. TotalView will support applications devel-
oped on this platform.

You’ll find a complete list of supported platforms and compilers in the TotalView 
Platforms and System Requirements Guide.

New and Changed Features

Version 8.9 Features

Support for CUDA 3.0 on Linux x86 and Linux x86-64 has been added. The follow-
ing features are included:

Tesla and Fermi hardware support 
Device (not emulator) support
CUDA function inlining support
CUDA memcheck functionality support
Linux threads and GPU device threads visibility
Representation of hierarchical memory with type qualification
Display and navigation using logical thread and block coordinates and hard-

ware coordinates
Breakpoints and stepping code running on the device
Interoperability with MPI for use in accelerated clusters

A 2D array viewer enables viewing a multi-dimensional array in a two-dimensional 
grid, allowing for setting the slice and stride within the dimensions to limit the 
amount of data in view. It includes a mechanism for controlling the numerical preci-
sion of the data displayed.

C++View is an extension of TotalView’s type transformation facility, to allow for-
matting functions to be written in the user’s target code and preferred language 
rather than in TCL code in the debugger.

http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
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The parallel backtrace feature provides a single view to the state of every pro-
cess/thread in a parallel job. It displays the host, status, process ID, rank and the 
line of code being executed.

TVScript support has been expanded to include the Cray XT, Blue Gene/L and Blue 
Gene/P platforms.

The Data Window supports display of very long C++ expressions.

Version 8.8 Features

This section lists the changes made for version 8.8 of TotalView.

A Remote Display client for the Mac and Windows 7 operating systems has 
been added.

Runtime performance at scale has been improved.

Version 8.7 Features

This section lists the changes made for version 8.7 of TotalView.

TotalView includes the MemoryScape GUI for memory debugging, with Red 
Zones on Linux platforms for detection and immediate notification of errors in 
heap arrays. 

Support for various heterogeneous debugging combinations and Power PC 32 
cross debugging is introduced. 

Remote debugging is enhanced to support IP-only networks and nodes with 
multiple interfaces with different IP addresses. 

TotalView allows subset attach from the command line and via the CLI. 
New server launch CLI state variables and shared library search and mapping 

state variables are added, and the search path and mapping rules are 
changed. 

Version 8.6 Features

This section lists the changes made for version 8.6 of TotalView.

Remote Display: TotalView can open a window on your machine that displays 
TotalView executing on a remote system. We provide installers for Windows 
running XP or Vista, Linux x86 and Linux x86-64. While Remote Display can 
only run on these operating systems, the remote TotalView can execute on any 
platform that TotalView supports.Information on running Remote Display is at 
http://www.roguewave.com/support/product-documentation/totalview-fam-
ily.aspx#totalview.

TVScript / Batch debugging: TotalView can run unattended using the tvscript 
shell command. The commands that tvscript executes can be entered as com-
mand-line options or by creating a file for tvscript to execute. Chapter 4 of the 
TotalView Reference Guide explains how to use the tvscript command. This docu-
ment is at http://www.roguewave.com/support/product-documentation/to-
talview-family.aspx#totalview.

Debug is added to the TotalView menubar if you are running on Linux-x86 and 
Linux-x86-64. All memory commands are now within Debug.

The current line is highlighted in yellow. If you have purchased a Replay license, 
an orange highlight line shows where you’ve gone back to. A separate marker 
shows the PC that existed when you entered replay mode.

http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
http://www.roguewave.com/support/product-documentation/totalview-family.aspx#totalview
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The dhistory command lets you invoke ReplayEngine from within the CLI. The 
spurs command displays information on spurs library use.

Options supporting ReplayEngine are added to dattach, dload, and stepping 
commands such as dstep, dnext, duntil, etc.

Options to the dload command let you start MPI programs. These options are 
–mpi, –nodes, –starter_args, –np, –procs, and –tasks.

The Process > Startup Parameters dialog is rearranged and contains options for 
enabling memory debugging and ReplayEngine. This window comes up auto-
matically when you start TotalView using a program’s name as an argument. 

Other command-line options added for this release include 
–local_interface (most often used with Blue Gene), –memory_debugging, and –
replay.

New variables added at this release are TV::ask_on_cell_spu_image_load, 
TV::cell_spu_image_ignore_regexp, TV::cell_spu_images_stop_regexp, 
TV::cell_spurs_jm_name, TV::cell_spurs_kernel_dll_regexp, 
TV::cell_spurs_ss_name, TV::cell_spurs_tm_name, TV::data_format_int128, 
TV::local_interface, and TV::GUI::heap_summary_refresh.

Version 8.5 Features

No changes are listed for version 8.5 of TotalView.

Version 8.4 Features

This section lists the changes made for version 8.4 of TotalView.

If you have more than one TotalView license, you can control which kind of li-
cense TotalView uses by adding one of the following command-line options: –
team, –noteam, –teamplus, –noteamplus, –ent or –noent. For more informa-
tion, see Chapter 6 of the “TotalView Reference Guide.”

The TotalView Memory Debugger can now write light-weight memory debug 
files when an event occurs. These files are similar to the memory debugging 
files (.mdbg) files that you can write using the File > Export command. They 
differ in that they are designed to be written when the event occurs and in 
such a way that the program’s behavior is minimally disturbed. These files are 
described in the Chapter 3 of the “Debugging Memory Problems with TotalView” 
Guide.

Improved support for C++ templates.
Improved support for Fortran modules on Apple Mac OS X.

Version 8.3 Features

This section lists the changes made for version 8.3 of TotalView.

Improvements to the way TotalView launches MPI programs let you use To-
talView with virtually every MPI library, even with those that were not config-
ured for debugging.

TotalView now highlights changes to values displayed in the Variable and 
Expression List windows with a colored background.

 

While this figure shows a simple variable, TotalView also highlights changed ele-
ments within compound variables such as structures and arrays.
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Values in the Variable and Expression List windows have a Previous value hidden 
column that you can display. Use the control on the right side of the column 
headings to display a list of columns that you can display or hide. 

When a process hits a breakpoint, TotalView highlights the breakpoint by plac-
ing an arrow over the breakpoint ID in the Action Points pane.

View > Show Across replaces View > Laminate in the Variable window's 
menus. This means the commands you will now use are View > Show Across 
> Process and View > Show Across > Thread.

You can now tell TotalView to show a variable across processes or threads by 
right-clicking on it in the Source Pane, then selecting either Across Processes or 
Across Threads from the context menu.

Figure 1:  Highlighted Change in the Variable Window
 

Figure 2:  Last Value Column
 

Figure 3:  Highlighted Action Point ID
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The Create Watchpoint command was added to the Action Points menu. As al-
ways, you can create a watchpoint from within the Variable window by select-
ing Tools > Create Watchpoint.

You can now set a watchpoint upon a variable’s memory address by right-click-
ing on the variable in the Source pane and then selecting Create Watchpoint 
from the context menu.

You can completely expand or collapse information in the Variable window by 
selecting an icon in the toolbar. The accelerators for these commands are 
Ctrl++ (that’s the control key and the + symbol) and Ctrl+- (which is the con-
trol key and the - symbol). 

TotalView no longer stops by default when your program loads a library. 
You can specify more than one core file on the command line and you can use 

wildcards in core file names.
There is a new Events View report within the Memory Debugger Heap Status 

tab.

Within the Memory Debugger’s File > Import Data dialog box, you can select 
multiple memory debugging (.mdbg) files.

Figure 4:  Event View
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Version 8.2 Features

This section looks at changes that have occurred within TotalView.

Early-Access GUI Installer
You can now install TotalView from tar files as you’ve always done or install it 
using our new graphical installer. We are calling this an early-access release in 
that we want you to tell us what you think of it and how we can improve it.

Fortran Parameter Display
TotalView now displays the value of Fortran parameters. Parameters can be 
used like variables in expressions but could not previously be examined within 
the debugger.

Versions 8.0 and 8.1 Features

Breakpoint Changes
Action points are considerably more powerful. Here is a summary:

The Action Point > At Location command now has three choices: 
Function or Line: lets you set a line number or a function name. This choice is 

what occurred in previous TotalView releases.
All Methods in Class: lets you set a breakpoint on all methods in a class. This 

can set more than one breakpoint.
All Virtual Functions and Overrides: lets you set breakpoints on virtual func-

tions and their overrides. This too can set more than one breakpoint.

You can now tell TotalView that a breakpoint will occur in a library that will be 
loaded later and that TotalView should retain knowledge of this breakpoint. 
This allows it to be set when the library is read. Previously, TotalView had to 
create and set breakpoints at the same time. This meant that when you enter 
a name into the At Location dialog box and the name is not yet known, To-
talView, displays either an Ambiguous Function or a Question dialog box. At 
this time, you can set the breakpoint’s status to pending. 

Figure 5:  Breakpoint > At Location Dialog Box
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When you create a barrier breakpoint or change a breakpoint to a barrier point, 
the same new features are available.

The CLI dbreak, dbarrier, and dlist commands have been extended to use these 
features. The argument to these commands can now be a breakpoint expres-
sion. Understanding this concept reveals some of the subtleties involved using 
these new features. These concepts are explained with the dbreak pages of 
the TotalView Reference Guide.

Other Features
This section describes improvements and changes made in many different places 
in TotalView.

The way in which you set search paths has changed.
)

You have told us that most of the time, you usually do not need to set search 
paths. If you do, you just need to enter a couple of paths. This is what the old 
dialog box was designed for. (You can still do this by typing paths directly into 
the EXECUTABLE_PATH tab.) However, when your programs make the transition 
from modules being developed on your workstation to an place where the work 
of development teams is brought together, setting search paths was tedious 
and difficult to get right. This new dialog box, extensively documented in the 
help, lets you solve this problem.

The File > New Program dialog box has changed. Much of what you will see 
makes the dialog box more usable. Most notable is the way you attach to pro-
cesses. The dialog box now lets you select more ethan one process at a time. 
The one new feature is that you can now enable memory debugging from this 
dialog box. 

The View> Freeze command is added to the Variable window. This command 
tells TotalView that it should freeze the contents of a Variable window. That is, 
as your program executes and as data values change, the contents of this win-
dow does not change. In most cases, you will also create a second Variable 
Window so that you can see old and new values at the same time. 

Figure 6:  Setting Pending Breakpoints
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The View > Lock command is added to the Variable Window. This command 
tells TotalView that it should not change the address from which the Variable 
Window is obtaining information. 

New dheap –compare CLI command options. This options lets you compare 
the result of two different memory states.

Figure 7:  File > Search Path Dialog Box
 

Figure 8:  File > New Dialog Box
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New dkill –remove CLI command option. Using this option to tell TotalView 
that, in addition killing the process, it should remove knowledge of the pro-
cess. This is seldom necessary. However, if you are using TotalView Team, using 
this option makes the token used by a process available to another process in 
your program.

The following CLI variables were added for this release
TV::env: sets an environment variable.
TV::bluegene_server_launch_string: sets the Blue Gene server launch string.
TV::default_sterr_append: tells TotalView to append stderr information to 

stdout.
TV::default_stderr_filename: tells TotalView to write stderr information to a 

file.
TV::default_stderr_is_stdout: tells TotalView to write stderr information to 

stdout.
TV::default_stdin_filename: Tells TotalView to read stdin information from a 

file
TV::default_stdout_append: Tells TotalView to append stdout information to 

a file
TV::default_stdout_filename: Tells TotalView to write stdout information to a 

file.
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